1C8.2 получить список документов вводимых на основании

  •  А) Введите фразу для поиска и нажмите кнопку [Найти];
  •  Б) Выделите текст и нажмите на клавиатуре кнопку Insert для поиска совпадений в дальнейшем тексте;
  •  В) Для перехода к найденному сообщению нажмите ярлык слева от текста;
 Используйте клавиатуру:
  •  Ctrl-F - поиск средствами обозревателя;
  •  Insert / Shift / Ctrl - новый поиск выделенного текста;
  •  Вверх/Вниз - навигация по результатам поиска;
         
1. (dp200)
Надо получить список видов документа которые можно ввести на основании текущего вида. Подскажите кто в курсе как это сделать.
2. (Minton)
Можно так
3. (dp200)
Minton, это получается наоборот на основании каких документов можно ввести текущий. А надо то что можно ввести на основании текущего вида.
4. (Minton)
Тогда так:
5. (koto3abp)
Цитата: МойДок = Метаданные.Документы.ПоступлениеТоваровУслуг; // К примеру КоллекцияВсехДокументов = Метаданные.Документы; Для КАЖДОГО ДокументКоллекции ИЗ КоллекцияВсехДокументов Цикл А = ДокументКоллекции.ВводитсяНаОсновании; Для КАЖДОГО Док ИЗ А Цикл Если Док = МойДок Тогда Сообщить(ДокументКоллекции); Прервать; КонецЕсли; КонецЦикла; КонецЦикла; В свое время я долго промучился над решением этой проблемы
6. (AlexRasmus)
спасибо
x
ActionTeaser.ru - тизерная реклама