Бухта свободного общения
Уютное место для мятежных мыслей
 
         
Страницы:  1  
АвторСообщение

dp200
 
участник форума



6
dp200
Надо получить список видов документа которые можно ввести на основании текущего вида. Подскажите кто в курсе как это сделать.
Сообщение # 1 Отправлено: dp200 22.11.2013 11:31:19

Minton
 
участник форума




138
Minton
Можно так

Сообщение # 2 Отправлено: Minton 22.11.2013 17:32:59

dp200
 
участник форума



6
dp200
Minton, это получается наоборот на основании каких документов можно ввести текущий. А надо то что можно ввести на основании текущего вида.
Сообщение # 3 Отправлено: dp200 23.11.2013 08:02:51

Minton
 
участник форума




138
Minton
Тогда так:

Сообщение # 4 Отправлено: Minton 28.11.2013 03:36:55

koto3abp
 
участник форума



7
koto3abp
  • Цитата: 
  • МойДок = Метаданные.Документы.ПоступлениеТоваровУслуг; // К примеру
    КоллекцияВсехДокументов = Метаданные.Документы;

    Для КАЖДОГО ДокументКоллекции ИЗ КоллекцияВсехДокументов Цикл
    А = ДокументКоллекции.ВводитсяНаОсновании;
    Для КАЖДОГО Док ИЗ А Цикл
    Если Док = МойДок Тогда
    Сообщить(ДокументКоллекции);
    Прервать;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;

    В свое время я долго промучился над решением этой проблемы
    Сообщение # 5 Отправлено: koto3abp 16.06.2014 18:13:49

    AlexRasmus
     
    участник форума



    8
    AlexRasmus
    спасибо
    Сообщение # 6 Отправлено: AlexRasmus 19.07.2014 09:09:53
    Страницы:  1  
    ВНИМАНИЕ!
    Посетители, находящиеся в группе Гости, не могут оставлять свои сообщения. Для регистрации пройдите по ссылке: зарегистрироваться.
    Форум